Call Quality Issues

Incident Report for Phone.com, Inc.

Resolved

This incident has been resolved.
Posted Sep 25, 2021 - 20:03 EDT

Monitoring

Our technology partner has identified the root cause of this incident and is observing improved network behavior. We continue to monitor the event and will post more information when it is available.
Posted Sep 25, 2021 - 19:31 EDT

Identified

The issue has been identified as a service impairment one of our technology partners is currently experiencing. Inbound calls continue to be impacted for some customers. We are closely monitoring the situation and will provide an update when a resolution is available.
Posted Sep 25, 2021 - 17:25 EDT

Investigating

We are currently experiencing an issue impacting calling for some customers. We are working urgently to identify the cause and correct the problem. We will provide additional information and an estimated time of resolution when it is available.
Posted Sep 25, 2021 - 16:33 EDT
This incident affected: Voice Network, Phone.com Communicator, My.Phone.com, and Mobile Application.