Users Unable to Make Outbound Calls
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 15:26 EDT
Investigating
Some users cannot make outbound calls from My.Phone.com or the Phone.com mobile app for iOS. Our team is investigating this issue with urgency. We will provide updates when available.
Posted Apr 24, 2023 - 11:48 EDT
This incident affected: Voice Network, My.Phone.com, and Mobile Application.