My.Phone.com / Admin Portal
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 19:31 EST
Identified
My.Phone.com and our admin portal (configure.phone.com and control.phone.com) are experiencing a partial service outage. Users may not be able to access them, or requests will be slow to be processed. We are investigating the active issue and will update shortly.
Posted Feb 23, 2021 - 16:28 EST
This incident affected: Control Panel.