IP device calling impairment

Incident Report for Phone.com, Inc.

Resolved

Our team has implemented a fix for this issue. Please power cycle your device (turn it off and then back on) to resolve the issue. More information about the cause will be available soon.
Posted Apr 23, 2025 - 17:02 EDT

Investigating

We are investigating an issue that is preventing some customers from receiving calls on IP devices. We will provide more information as it becomes available.
Posted Apr 23, 2025 - 14:41 EDT
This incident affected: Voice Network and Desk Phones.