Service Impairment
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 16:28 EST
Investigating
Phone.com is experiencing a service impairment affecting outbound calling. This impairment is being investigated.
Posted Feb 13, 2020 - 15:47 EST
This incident affected: Voice Network.