Phone.com Call Center Service Disruption
Incident Report for Phone.com, Inc.
Resolved
Our technology partner has resolved the issue, and our support lines are working as expected. Thank you for your patience.
Posted Feb 08, 2022 - 21:54 EST
Investigating
We are currently experiencing a service impairment that is preventing calls from reaching our customer support and sales agents. We are working with our technology provider to resolve this urgently. Meanwhile, you can submit a request on this form, and one of our agents will reach out to you. We will update this page when more information and an estimated time of resolution is available.
Posted Feb 08, 2022 - 21:24 EST
This incident affected: Customer Service - Sales & Support Lines.