Contact center wait times are longer than normal.
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 19:24 EDT
Monitoring
We are currently experiencing longer than normal telephone hold times for our support agents. If you’d rather not wait, please visit www.phone.com/support and submit a ticket. One of our agents will reach out as soon as they are available.
Posted Mar 18, 2022 - 12:57 EDT
This incident affected: Customer Service - Sales & Support Lines.