Signup Impairment
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 13:11 EDT
Investigating
We are investigating an issue preventing people who attempt to sign up for Phone.com from selecting a phone number. We are working to resolve it quickly. If you cannot select a number during the signup process, please try again later.
Posted Sep 15, 2023 - 10:10 EDT
This incident affected: Phone.com Website.