Support Lines Impaired
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 15:14 EDT
Update
Our teams can be contacted at 877-746-6310. We are still working on a fix for our main support number.
Posted Sep 28, 2020 - 18:48 EDT
Identified
The issue has been identified and we are working on a fix. Our team can be contacted via chat.
Posted Sep 28, 2020 - 17:40 EDT
This incident affected: Customer Service - Sales & Support Lines.