Impairment to Customer Service and Sales Telephone Lines

Incident Report for Phone.com, Inc.

Resolved

This incident has been resolved.
Posted Mar 28, 2022 - 12:50 EDT

Investigating

Our technology partner is experiencing an impairment that is impacting our customer service and sales telephone lines. They are working urgently to resolve the issue. If you need assistance, please submit a report request at https://www.phone.com/support-request/ and one of our agents will assist as quickly as possible.
Posted Mar 28, 2022 - 11:23 EDT
This incident affected: Customer Service - Sales & Support Lines.