Partial Service Impairment
Incident Report for Phone.com, Inc.
Resolved
The issue with our vendors have been resolved.
Posted 11 months ago. Sep 07, 2018 - 18:26 EDT
Monitoring
We are experiencing a partial service impairment. Some of our devices that frequently register with us may experience partial loss or interruptions to dial tone.

One of our main service providers is having an issue. We are actively working with them to resolve the issue. Appreciate your patience and understanding. Should you have any concerns, please dial our main service line at 800.998.7087

Thank you.
Posted 11 months ago. Sep 07, 2018 - 18:05 EDT
This incident affected: Voice Network and Phone.com Website.