My.Phone.com Calling Impairment
Incident Report for Phone.com, Inc.
Resolved
This issue has been resolved.
Posted May 16, 2023 - 13:01 EDT
Investigating
We are investigating a reported intermittent issue preventing some users from making or receiving calls using My.Phone.com.

This issue does not impact the mobile apps or physical phones.

We are working urgently to resolve this and will provide updates when available.
Posted May 16, 2023 - 11:56 EDT
This incident affected: My.Phone.com.