Fax and Voicemail Impairment
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 16:45 EST
Investigating
We are currently investigating an issue related to sending faxes and incoming voicemails. We will update when more information becomes available.
Posted Dec 14, 2021 - 13:37 EST
This incident affected: Control Panel and Voiocemail.