Sales & Support Lines
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 14:25 EDT
Identified
We have identified an issue with a 3rd party vendor impacting inbound calls to our toll-free support number. Phone.com services have NOT been effected and are 100% functional. If you need any assistance, you can contact us via Live Chat or submit a request at https://www.phone.com/support-request/?category=technical_support
Posted Aug 06, 2020 - 13:19 EDT
This incident affected: Customer Service - Sales & Support Lines.