Call Recording Latency
Incident Report for Phone.com, Inc.
Resolved
This issue has been resolved. Thank you for your patience.
Posted Oct 13, 2022 - 01:58 EDT
Investigating
We are currently experiencing a delay in the availability of call recordings. Our team is investigating. We will update this page when more information is available.
Posted Oct 12, 2022 - 18:28 EDT
This incident affected: Control Panel and My.Phone.com.