Phone.com site is down
Incident Report for Phone.com, Inc.
Resolved
The Phone.com website is back and fully operational. We are continuing to monitor the situation.
Posted Sep 29, 2021 - 20:24 EDT
Investigating
Our hosting provider is currently experiencing service interruptions. We are investigating and will provide additional information once it is available.
Posted Sep 29, 2021 - 19:24 EDT
This incident affected: Phone.com Website.