My.Phone.com Audio Issue
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 21:56 EST
Update
Our team is continuing the investigation to fix this issue, which solely affects My.Phone.com. Other audio services are all operating normally.
Posted Nov 21, 2022 - 17:51 EST
Investigating
We are currently experiencing an issue resulting in no audio for some customers using My.Phone.com.

We are working urgently to identify the cause and correct the problem. We will provide additional information and an estimated resolution time when it is available.
Posted Nov 21, 2022 - 15:50 EST
This incident affected: My.Phone.com.