Service Impairment
Incident Report for Phone.com, Inc.
Resolved
Customer service phone line was restored as of 5:45PT.
Posted 4 months ago. Apr 09, 2019 - 22:42 EDT
Investigating
Due to a service impairment with our vendor, Phone lines to our customer support team are not operating. Lines should be up shortly but in the meantime please use chat or email to reach us https://www.phone.com/support/
Posted 4 months ago. Apr 09, 2019 - 18:50 EDT
This incident affected: Customer Service - Sales & Support Lines.