Users Unable to Login to Mobile Apps
Incident Report for Phone.com, Inc.
Resolved
Our engineering team has released a version of the Phone.com app for iOS that solves the log in issue. The new version is 5.6.39. Users can install it from the App Store. You may need to uninstall the old version and install the new one. Thank you for your patience during this incident.
Posted Mar 15, 2023 - 11:08 EDT
Update
Our engineering team has released a version of the Phone.com app for Android that solves the login issue. The new version is 27.0.19. Users can install it from the Play Store.

We expect a similar fix for iOS very soon.
Posted Mar 13, 2023 - 20:14 EDT
Update
Our engineering team has uncovered and resolved the cause of this issue. We are in the process of deploying the fix with the mobile app stores. The updates will be available when the app store reviews are complete. We will notify you when that is done.
Posted Mar 13, 2023 - 12:39 EDT
Update
Our engineering teams continue to work on this issue. The nature of the issue requires us to work with our technology partners and mobile app store ecosystems. We will provide more updates as soon as we have more to share. Based on the progress we have made thus far, we are optimistic that this will be resolved soon.
Posted Mar 11, 2023 - 12:23 EST
Identified
Our Engineering Teams are diligently working on this issue. The nature of the issue requires us to work with our technology partners and mobile app store ecosystems. We will provide more updates as soon as we have more to share. Based on the progress we have made thus far, we are optimistic that this will be resolved soon.
Posted Mar 10, 2023 - 11:54 EST
Update
We continue to work on resolving this issue. Meanwhile, if you are having trouble logging into the mobile apps, you can access Phone.com by logging into https://My.Phone.com from your mobile browser. Your patience is appreciated.
Posted Mar 07, 2023 - 18:48 EST
Update
We are working with our service partner to resolve the mobile app login issue for both iOS and Android users. This issue should not impact customers who are already logged in.
Posted Mar 07, 2023 - 13:26 EST
Investigating
We are experiencing an issue preventing some users from logging into our mobile apps. We understand the critical nature of this problem and are working urgently to resolve it. We will provide more information as it becomes available.
Posted Mar 07, 2023 - 12:35 EST
This incident affected: Mobile Application.