Administrative Control Panel Impairment
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 11:16 EDT
Investigating
We have received reports of prolonged response and load times for our administrative control panel. Our engineering team is actively investigating this issue and working to resolve it as quickly as possible. We will provide updates when more information is available.
Posted Jul 27, 2023 - 09:08 EDT
This incident affected: Control Panel.