My.Phone.com, the mobile apps, and Configure.Phone.com are unavailable for some users.
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 21:29 EDT
Identified
One of our technology partners is experiencing an impairment impacting Phone.com customers' ability to access and use our applications. We are working closely with our partner as they work to resolve this issue. More information and an estimated time of resolution will be provided when it is available.
Posted Sep 18, 2023 - 17:24 EDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 15:20 EDT
Investigating
Some users are unable to access My.Phone.com, the mobile apps and Configure.Phone.com. Our team is actively investigating the issue with all urgency. We will provide updates when more information becomes available.
Posted Sep 18, 2023 - 14:45 EDT
This incident affected: My.Phone.com, Mobile Application, and Configure.Phone.com.