Intermittent Impairment
Incident Report for Phone.com, Inc.
Resolved
The service issues we were experiencing earlier have been resolved. We have requested a root cause analysis from our partners.
Posted Sep 14, 2021 - 18:05 EDT
Investigating
We are investigating an issue that is causing impairment to our messaging, number management, and notifications system. We will update when we have a resolution.
Posted Sep 14, 2021 - 15:22 EDT
This incident affected: Control Panel, My.Phone.com, Mobile Application, and Configure.Phone.com.