Degraded Voice Network
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 13:15 EDT
Update
The issue has been identified with some of our vendors and we are continuing to work on a fix.
Posted Apr 21, 2020 - 13:00 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 21, 2020 - 11:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2020 - 11:10 EDT
This incident affected: Voice Network.