Intermittent Inability to Add Numbers
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 16:45 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 06, 2023 - 13:09 EST
Investigating
There have been reports of intermittent issues when attempting to add Toll-Free and Local Numbers. Our team is currently investigating.
Posted Nov 06, 2023 - 11:28 EST
This incident affected: Control Panel and Configure.Phone.com.