Phone.com Customer Service numbers - down briefly
Incident Report for Phone.com, Inc.
Resolved
Issue resolved as of 12:15PM Pacific Time.
Posted about 1 year ago. Aug 07, 2018 - 15:29 EDT
Investigating
We had a local power outage in our San Diego facility. The cable and internet connectivity were impacted from 12:05PM - 12:15PM Pacific time. Customers calling into customer service lines were impacted temporarily. All services are back online as of 12:15PM. We apologize for the inconvenience.
Posted about 1 year ago. Aug 07, 2018 - 15:29 EDT
This incident affected: Phone.com Website.