Phone.com Unavailable on Google Play Store
Incident Report for Phone.com, Inc.
Resolved
This issue has been resolved and the Phone.com app is now available on the Google Play Store.
Posted Jan 29, 2022 - 12:36 EST
Identified
The Phone.com mobile app for Android is temporarily unavailable on the Google Play Store for new installations. We are working urgently to resolve the issue. Users who have already downloaded the app can use it as expected. If you would like to download the app now, you may do so at: https://drive.google.com/file/d/1-sprQYwHQkWNQe3DhvaNYAxt0pgaJTyR/view?usp=sharing
Posted Jan 28, 2022 - 12:56 EST
This incident affected: Mobile Application.