Video Meetings Impairment
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 13:52 EST
Investigating
We are currently experiencing an issue preventing users from logging into their meeting rooms or initiating video meetings. We are working urgently to identify the cause and resolve the issue. We will update this page with more information and an estimated time of resolution as soon as we have more information.

Telephone conferencing is not affected.
Posted Nov 13, 2024 - 13:25 EST
This incident affected: Video Meetings.