Service Impairment update
Incident Report for Phone.com, Inc.
Resolved
All services have been restored and are operational. We will provide more details and an explanation as we complete our investigation.
Thank you all for your patience.
Posted over 1 year ago. Apr 19, 2016 - 14:14 EDT
Investigating
Starting at 8:15 PT some Phone.com services have been impaired due to a cyber-attack on our network. We will provide more information as soon as we have an update. We appreciate your patience and apologize for the service outage.
Posted over 1 year ago. Apr 19, 2016 - 12:34 EDT