Partial Outage
Incident Report for Phone.com, Inc.
Resolved
all services are fully operational
Posted almost 2 years ago. Dec 02, 2015 - 16:41 EST
Investigating
Due to a network impairment calls to and from some Phone.com devices are not working. Calls can be forwarded to or from any Phone.com number to any other phone number. All services should be operational soon and we will provide an update in 15 minutes.
Posted almost 2 years ago. Dec 02, 2015 - 16:19 EST