Inbound CenturyLink Toll Free Numbers not connecting
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 18, 2016 - 18:41 EDT
Monitoring
This morning (7/18/2016) we identified an issue with inbound calls to CenturyLink toll free numbers. This incident started at about 9 AM PDT and was resolved at 9:49 AM PDT. Less than 1% of inbound calls were affected. We are continuing to monitor the issue.
Posted over 1 year ago. Jul 18, 2016 - 14:09 EDT