Inbound calling impairment
Incident Report for Phone.com, Inc.
Resolved
All numbers are working now. Due to a database upgrade some live numbers were affected for inbound calling. All numbers have been restored to order.
Posted over 1 year ago. Apr 13, 2016 - 16:57 EDT
Investigating
Some customers may be experiencing problems receiving inbound calls on some of their numbers. We are actively investigating.
Posted over 1 year ago. Apr 13, 2016 - 14:39 EDT