Some customers reporting no service.
Incident Report for Phone.com, Inc.
Resolved
The issue was resolved at 6:57 AM PDT.
Posted 10 months ago. Oct 24, 2016 - 10:19 EDT
Investigating
We are investigating some reports of calls failing to dial out and inbound calls with no audio.
Posted 10 months ago. Oct 24, 2016 - 10:04 EDT