Update
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 04, 2015 - 09:24 EST
Monitoring
As CEO of Phone.com and on behalf of all of us in the company, I wanted to sincerely apologize for the service disruptions that occurred recently. As customers depending on our services to be available 100% of the time, we recognize that any disruptions are unacceptable. As your service provider, it is our job to manage these services to the highest degree possible. I felt it right to share with you what happened: the problem occurred due to an “attack” on our network which is unfortunately still a reality of life in the Internet era. Such attacks cause “fake” overloads on the network. We can now happily say that we believe we have mitigated the problem. We are actively and constantly implementing processes, procedures, and systems to avoid similar issues in the future. Further, we are in the process of a major overall upgrade to our network, which will improve quality, reliability, and add more capabilities to our service.
If you would like more specific technical details as to the reasons for the service outages, I am happy to schedule a call at your convenience. In general, though, it is important to note that I- based voice traffic is different from traditional old land line phone service. With IP-based service, we can offer many more features and services that are not available or cost a fortune with old landlines. IP voice communication does behave more like Internet traffic and therefore could be affected by Internet connectivity to some extent, like mobile phone service has its shortcoming and is affected by cell coverage.
Thank you for your patience and continued support and know that we take these events very seriously. We will not stop until we have permanently addressed these challenges.
Ari Rabban, CEO
Posted almost 2 years ago. Nov 03, 2015 - 12:56 EST