800 Service and Support Number is down
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 22, 2016 - 22:58 EDT
Investigating
Our Support Number 800-998-7087 is currently down. This number is hosted by a third party; the Phone.com voice network is not affected by this issue. For service and support please go to support.phone.com and click on the Chat link to use our LiveChat system, or send an email to support@phone.com.
Posted over 1 year ago. Aug 22, 2016 - 21:18 EDT