Voicemail recordings may be delayed for some customers
Incident Report for Phone.com, Inc.
Resolved
All recording services are back to normal. If you have any delays please contact our customer service team.
Posted over 1 year ago. May 04, 2016 - 20:15 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. May 04, 2016 - 17:29 EDT