Number not working
Incident Report for Phone.com, Inc.
Resolved
This incident has been resolved.
Posted about 2 years ago. Apr 04, 2016 - 17:23 EDT
Investigating
Hello,
We have discovered an issue affecting a small amount of our phone numbers which may affect some incoming calls. We are currently working to resolve this issue as quickly as possible. Thank you for your patience.
Posted about 2 years ago. Apr 04, 2016 - 15:54 EDT