Minor Service Outage 8-30-2016
Incident Report for Phone.com, Inc.
Resolved
Issue resolved at 1049 AM PDT.
Posted over 1 year ago. Aug 30, 2016 - 13:55 EDT
Investigating
Partial Outage - We are currently investigating.
Posted over 1 year ago. Aug 30, 2016 - 13:38 EDT