International Dialing issues.
Incident Report for Phone.com, Inc.
Resolved
As of 8:30AM PDT (11:30AM EST), International outbound calling service has been restored. We were able to work with our carrier and resolve the issue. All calls to international destinations are now operational. Thank you for your support.
Posted almost 2 years ago. Sep 15, 2015 - 12:02 EDT
Investigating
We are experiencing intermittent issues with dialing out international numbers. The problem has been raised to our international carrier and they are actively working with us for a speedy resolution. This only impacts outbound international calling. We will keep you updated on resolution of this issue.
Posted almost 2 years ago. Sep 15, 2015 - 11:04 EDT