Some in-bound calls are not ringing through.
Incident Report for Phone.com, Inc.
Resolved
The Level 3 carrier issue was resolved at approximately 9:30 AM PDT.
Posted about 1 year ago. Oct 04, 2016 - 12:58 EDT
Update
The on-going inbound calling issue is related to a Level 3 carrier problem with some numbers. We're continuing to investigate and working with the carrier to resolve the issue.
Posted about 1 year ago. Oct 04, 2016 - 11:30 EDT
Investigating
Our Operations team is currently investigating the issue.
Posted about 1 year ago. Oct 04, 2016 - 11:15 EDT